CentOS 解决异常 error: SSL modules require the OpenSSL library

原创 HuangLongPu     发表于  2022-05-10 15:41       19
原文链接:

在 CentOS 系统下安装软件,例如 Nginx,编译时有时会提示异常:

./configure: error: SSL modules require the OpenSSL library.
You can either do not enable the modules, or install the OpenSSL library
into the system, or build the OpenSSL library statically from the source
with nginx by using --with-openssl=<path> option.

出现这样的异常信息,是由于缺少依赖所导致。执行如下命令安装依赖即可,如下:

yum -y install openssl openssl-devel

相关文章

HuangLongPu
5
26475/45000
文章数
190
阅读量
100437
原创
147
广告
公众号
QQ讨论群